Vietnamen’s Weblog

Time, Chances, Diligence, Intelligence: which is the most important?

Ubuntu

with one comment

Emacs

Error: File ~/.ido.last cannot be modified.

Solution: open terminal, hits

$sudo chmod 644 ~/.ido.last

Error: pfb2pfa: not found

…. tmp_…..pfa not readable in ‘load_string’

Solution: install texlive-fonts-utils and texlive-fonts-extra

Firefox

  • If you has this error:
Firefox is already running, but it not responding. To open a new window, you must first close the existing Firefox process,..."
But there is no firefox processs when you search using: ps -e | grep firefox

The only way is to copy everything in ~/.mozilla and then delete this folder: rm -rf ~/.mozzila

Now, it works.

  • If there is no address bar (url bar), click View/Toolbar/Customize… and drag the “Address bar” icon out.

Hibernate:

Error: Cannot find swap device, please try swapon -a.

Correct: If /dev/sda5 is the swap partition, then call the following 2 commands:

$sudo mkswap /dev/sda5
$sudo swapon /dev/sda5

Error: hibernate does not work with your laptop. Remember that Ubuntu use the swap partition to save the current state of your machine, and use the UUID (universal unique ID) to identify a partition. So, use

$ blkid

/dev/sda6: UUID=”98c56a53-2ac7-4828-af9a-06e2ad05f2c8″ TYPE=”swap”

and then make sure the one in this file: /etc/initramfs-tools/conf.d/resume is the UUID of your swap partition.

Update the content of resume and execute:

$ sudo update-initramfs -u
References:

  1. http://ubuntuforums.org/showthread.php?t=915659

MultiDesktop

Ubuntu allows you set up more than one desktop windows at a time (right-click on the bottom taskbar and choose Preferences).  There is also such a neat function that allows you to switch from one desktop to another easily. Press Window-E, then right-click on the windows you want.

Opera

The displaying font is so disgusted. It looks thinner and there are overlapped sometimes between characters, specially when you zoom the web page in using Ctr-mouse scroll (Ctrl-+). The good solution is to open the page “opera:config”, find User prefs –> disable “Enable Core X fonts“. Restart Opera.

References:

  1. http://my.opera.com/community/forums/topic.dml?id=185329

Undo closed tab: Press Ctrl-Z

Swap

Error: Swap partition is disabled

Correct: Run  blkid to find the block ID of the swap partition

…:~$ blkid
/dev/sda1: SEC_TYPE=”msdos” LABEL=”DellUtility” UUID=”07D6-061C” TYPE=”vfat”
/dev/sda2: UUID=”ECBCF760BCF7242C” TYPE=”ntfs”
/dev/sda4: LABEL=”DellRestore” UUID=”0000-0000″ TYPE=”vfat”
/dev/sda5: UUID=”CE9480B854D8185A” LABEL=”DATA” TYPE=”ntfs”
/dev/sda6: UUID=”98c56a53-2ac7-4828-af9a-06e2ad05f2c8” TYPE=”swap”
/dev/sda7: UUID=”d3ddddd4-bff3-5bb9-b323-a6c57d0f7272″ TYPE=”ext3″
/dev/sda8: UUID=”d3ddddd4-bff3-5bb9-b323-a6c57d0f7272″ TYPE=”ext3″
Copy this UUID and paste them in the file /etc/fstab on the swap line so that it looks like this

# /dev/sdb5
UUID=98c56a53-2ac7-4828-af9a-06e2ad05f2c8 none swap sw 0 0

Restart the system

References:

  1. http://ubuntuforums.org/showthread.php?t=691986

Ubuntu

Here discuss troubles occurred to the OS:

    • Top and bottom panel disappear –> Make sure you install gnome-panel

      sudo apt-get install –reinstall gnome-panel

      or

      gconftool-2 --shutdown
      rm -rf ~/.gconf/apps/panel
      pkill gnome-panel

        • If this error happen afterward: OAFIID:GNOME_FastUserSwitchApplet

          Make sure you install: sudo aptitude RET, press / (for search) and type user switch RET; it then jump to the package you need to install, press + for selection and press g (for install). Quit with q. Then logout and login again.

          References:

          1. http://ubuntuforums.org/showthread.php?t=156602
          2. http://ma65p.wordpress.com/2008/06/23/how-to-restore-the-original-panel-and-menu-bar-in-ubuntu/

          Update

          If there is such an error when calling: sudo apt-get update

          W: GPG error: http://ppa.launchpad.net intrepid Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 1234567890ABCDEF

          Here is the solution:

          $pgp --keyserver subkeys.pgp.net --recv  1234567890ABCDEF
          $pgp --export --armor 1234567890ABCDEF | sudo apt-key add -

          $sudo apt-get update

          It works.

          References:

          1. http://ubuntuforums.org/showthread.php?t=1053126

          Graphics

          ATI Radeon Mobility X1400

          Install these two packages (open synaptic)

          + xorg-driver-fglrx

          + xorg-driver-fglrx-dev

          Then open System\Administrator\Hardware Drivers and enable it.

          Dev/Compile

          checking for Qt… configure: error: Qt (>= Qt 3.0 and < 4.0) (headers and libraries) not found. Please check your installation!

          ====> install libqt3-headers

          checking for KDE…configure: error

          ====> install one-by-one, and run ./configure before you install a new version:  kdelibs4-dev, kdebase-dev, kdesdk-miscs, kdenetwork-dev


          Written by vietnamen

          Tháng Hai 13, 2009 lúc 11:28 chiều

          Một phản hồi

          Subscribe to comments with RSS.

          1. thank you . it helped me very much

            vuau

            Tháng Tư 4, 2009 at 11:00 sáng


          Gửi phản hồi

          Mời bạn điền thông tin vào ô dưới đây hoặc kích vào một biểu tượng để đăng nhập:

          WordPress.com Logo

          Bạn đang bình luận bằng tài khoản WordPress.com Log Out / Thay đổi )

          Twitter picture

          Bạn đang bình luận bằng tài khoản Twitter Log Out / Thay đổi )

          Facebook photo

          Bạn đang bình luận bằng tài khoản Facebook Log Out / Thay đổi )

          Google+ photo

          Bạn đang bình luận bằng tài khoản Google+ Log Out / Thay đổi )

          Connecting to %s

          %d bloggers like this: